Upcoming technologies, programming, problem solving, coding, technology, mobile phones
About us
Get link
Facebook
X
Pinterest
Email
Other Apps
In this blog you will be able to learn python-programming language and problem solving. You can also find solutions for hackerrank problems, google coding problems.
Solution for hackerRank problem Finding the percentage in python Problem : The provided code stub will read in a dictionary containing key/value pairs of name:[marks] for a list of students. Print the average of the marks array for the student name provided, showing 2 places after the decimal. Example The query_name is 'beta'. beta's average score is . Input Format The first line contains the integer , the number of students' records. The next lines contain the names and marks obtained by a student, each value separated by a space. The final line contains query_name , the name of a student to query. Constraints 2<=n<=10 0<=marks[i]<=100 length of marks arrays = 3 Output Format Print one line: The average of the marks obtained by the particular student correct to 2 decimal places. Sample Input 0 3 Krishna 67 68 69 Arjun 70 98 63 Malika 52 56 60 Malika Sample Output 0 56.00 Explanation 0 Explanation 0 Marks for Malika are whose average is Sample Input
1. Rearrangement Given a list A elements of length n , ranging from 1 to n. All elements may not be present in the array. If the element is not present then there will be -1 present in the array. Rearrange the array such that A[i]=i and if i is not present display -1 at that place. Input format : The first line contains a n numbers with each number separated by space. Output format : Print the elements of the list after modification. Sample input : -1 -1 6 1 9 3 2 -1 4 -1 Sample Output : -1 1 2 3 4 -1 6 -1 -1 9 Explanation : The modified list contains elements such that A[i]=i . Code : Output : 2. Formula Write a program that calculates and prints the value according to the given formula , Q=square root of [(2*C*D)/H]. Following are the fixed values of C and H , C=50 ,H=30. D is the variable whose values should be input to your program in a comma separated sequence. Input format : A sequence of values for D with each value separated by comma. Output format : Print the sequence of
Solution for hackerRank problem ginortS in Python Problem : You are given a string S. S contains alphanumeric characters only. 'SORTING' Your task is to sort the string S in the following manner: All sorted lowercase letters are ahead of uppercase letters. All sorted uppercase letters are ahead of digits. All sorted odd digits are ahead of sorted even digits. Input Format A single line of input contains the string S. Constraints 0 < len(S) < 1000 Output Format Output the sorted string S. Sample Input Sorting1234 Sample Output ginortS1324 Code : s = str(input()) Upper = [] lower = [] odd_no = [] even_no = [] for i in s: if(i.isupper()): Upper += [i] if(i.islower()): lower += [i] if(i.isnumeric()): if(int(i)%2 == 0): even_no += [i] else : odd_no += [i] Upper.sort() lower.sort() odd_no.sort() even_no.sort() Upper = "".join(Upper) lower = "".join(lower) odd = "".join(odd_no) ev
Comments
Post a Comment